<-- Back

How to resolve Mendix application scaling issues with Mendix on Kubernetes

Issue

A Mendix application cannot be scaled down by setting replicas:0. The application remains running, and the number of replicas/pods does not change. This issue also occurs when attempting to increase the number of replicas.

Environment

Applications hosted in Mendix on Kubernetes

Cause

The issue is caused by an expired trial version of the Mendix Operator. With an unlicensed Operator, environments created over 90 days ago can only be deleted, not scaled or modified.

Solution/Workaround

To resolve this issue, upgrade the Mendix Operator to version 2.23.0 or higher. Here are the steps to resolve the problem:

  1. Upgrade the Mendix Operator to version 2.23.0 or higher (recommended version: latest Mendix Operator)

  2. Upgrade to remove the Operator license restriction and scale applications as needed

  3. Verify that the Operator is showing as Licensed in the Private Cloud Portal

  4. Attempt to scale the application again using the YAML file or kubectl commands.

Note: Starting from version 2.23.0, only Runtime licenses are required to remove trial restrictions. The Operator will show its status as Licensed even when no specific Operator license is applied. 

Internal information related

  • 267310 

Additional information

Mendix documentation: 

Have more questions? Submit a request

0 Comments

Article is closed for comments.

To provide feedback, please open a ticket here. Don't forget to include the article's URL along with the feedback you would like to provide.