Issue
When an application is deployed to an environment in Mendix on Kubernetes and starts successfully, it is still not possible to log in using the MxAdmin user. Even though all tables and sequences are created in the database, the MxAdmin is not in the System$User table.
Environment
Applications hosted in Mendix on Kubernetes
Cause
It is an expected behavior that the administrator account (by default: MxAdmin) is not created upon startup. If the MxAdmin user is not created in the database, this is because the mxAdminPassword field was left blank while creating/editing the Mendix Custom Resource, which helps configure the license with the license credentials.
Solution / Workaround
When deploying an application, the system checks whether an MxAdmin account exists. If the account does not exist and the mxAdminPassword field is set, a new account is created. If the account already exists, its password is updated during deployment.
To create the MxAdmin user or update its password, it is necessary to:
Set the mxAdminPassword field in the YAML configuration, as described in Editing the CR document
After updating the configuration, deploy or redeploy your application
Internal information related
203922, 238756
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