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Monitoring nightly or automated backups on the Mendix Cloud

Issue

Automated backups are taken nightly for all environments running on Mendix Cloud. If the initial backup creation fails, it will be automatically retried. If this second attempt also fails, the backup is marked as failed. However, no notification or alert is sent once this happens.

Environment

Applications hosted in Mendix Cloud

Cause

Mendix does not monitor individual backups, as our monitoring system works on a cluster level. However, if all nightly backups fail, Mendix gets alerted, and will work on the issue.

The reason why only platform-wide issues are monitored by Mendix is because a nightly backup might fail due to several container-related issues, such as a container running out of disk pace. As most often the cause of the backup failing is related to the application specifically, we have opted to not monitor this, as it would flood the alert system.

Solution / Workaround

It is possible to monitor an application's nightly backups under the Backups tab in the Mendix Portal.

In case of a wide-spread issue with the backup infrastructure, Mendix has an alert system in place. Our RnD team will be alerted, and will resolve the infrastructure failures that are detected. For these cases, a Status Page will be created.

Internal information related

  • 252537, 267287 
  • BAK-2090

Additional information

  • Mendix documentation: Backups
  • Related KBA: KBA (hyperlink)
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