Issue
When a service is published through Mendix Cloud, it should automatically register in the Catalog. However, that is not the case, the endpoints are not being registered, and therefore they are not visible in the Catalog.
Environment
Applications hosted in Mendix Cloud
Cause
The endpoints are not being registered because the licensed node belongs to a different company, while the deployed app was created under another company.
Solution / Workaround
There are two options to resolve this, as outlined below :
- Create a new licensed node and ensure that both the app and the licensed node are owned by the same company. The owner of the licensed node owns the resources and metadata associated with the node. Therefore, a single company should own both the licensed node and the application.
- Mendix Admins can invite external users on the External Users tab. An external user is a user from outside of your organization who can search for published data sources and use them in apps.
The Catalog restricts access to non-public resources based on company ownership, meaning you must belong to the company that owns a resource to view it. If you are part of a different company but still require access for example, as a partner consultant working on behalf of a customer our external access system allows the customer’s company to grant you the necessary permissions.
Internal information related
- 257158
Additional information
Mendix documentation:
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