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Restore a backup created locally with pg_dump fails in Mendix Cloud

Issue

A backup created using pg_dump locally using pgAdmin (or another tool), a utility for backing up a PostgreSQL database, fails to restore in Mendix Cloud.

Environment

Applications in Mendix Cloud

Cause

There can be many reasons for this to happen, but this article covers the most likely problem. The backup was created with an unsupported pg_dump version. As outlined in our Restoring a Backup documentation, the backup (or dump) must be created with pg_dump version 1.15 or below, which is currently bundled with PostgreSQL 13, 14, and 15. If the dump is created with a later version, then the upload of that backup will fail.

Solution / Workaround

Create a backup (or dump) using PostgreSQL 13, 14, or 15, which includes pg_dump version 1.15, and try again. If pgAdmin, a graphical user interface tool for managing PostgreSQL databases that includes pg_dump, is used please make sure that PostgreSQL version 13, 14, or 15 is used. To check this, follow these steps:

  1. In pgAdmin, go to Preferences
  2. Select Paths > Binary paths > PostgreSQL Binary Path
  3. The binary path should match the database server

If the problem continues after creating a backup with pg_dump version 1.15, please reach out to Mendix Support.

Internal information related

  • 223610, 221023
  • [Internal] Failed to restore a backup in Mendix Cloud - pg_restore: error: unsupported version in file header

Additional information

Mendix documentation: Restoring a Backup

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