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IOException: Broken pipe and EofException in Mendix Cloud

Issue

The exceptions below can be found in the application logs

org.eclipse.jetty.io.EofException: null

followed by

Caused by: java.io.IOException: Broken pipe

While this exception does not impact the performance of the application, this article explains what those exceptions are and a solution to monitor them. 

Environment

Applications hosted in Mendix Cloud

Cause

The EofException indicates that a file transfer (send/receive) ended unexpectedly, usually because the connection was closed.

The IOException: Broken pipe indicates the application tried to write data to a connection that was no longer available. For example, this can happen if a request is received and the application starts processing it, but in the meantime, the browser is closed (or a web service ends the HTTP connection). When the application finishes processing and attempts to send the response, the connection is already gone.

Solution / Workaround

Since these errors usually do not impact application performance, it is recommended to review the following:

  • Log entries that appear before the EofException.
  • Check whether the issue began after a new deployment. If that is true, review the recent changes.
  • Monitor how often the error occurs and look for patterns.
  • Review client or network behavior. For instance, confirm if browsers are closed prematurely or if there are dropped connections.

Internal information related

  • 235319, 253486, 254903

Additional information

Not applicable

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