Issue
When emails are sent via the Email Connector module, the emails are quarantined in the recipient's mailbox and are marked as spam/junk.
Environment
Email Connector (all versions)
Cause
The issue arises because the Email Connector simply acts as an email client to connect to the server and send out emails. It does not handle DNS records like SPF and DMARC, which are necessary for email authentication and to prevent emails from being marked as spam or quarantined. These records must be added directly via the domain provider.
Solution/Workaround
By configuring the necessary DNS records through their domain provider, users can ensure that their emails are authenticated and prevent them from being quarantined. To resolve this issue, the following steps should be followed:
- Set Up a Third-Party Mail Service Provider:
- Ensure that a third-party mail service provider has been set up, as outlined in the Sending Email in Mendix Cloud documentation.
- Ensure that a third-party mail service provider has been set up, as outlined in the Sending Email in Mendix Cloud documentation.
- Configure DNS Records via Domain Provider:
- Add DMARC and SPF records to the DNS settings through the respective domain provider. These records help authenticate emails and prevent them from being quarantined. For more general information, consult What Are Sender Policy Framework Records? or What is a DNS SPF record?
- For example, users who make use of Microsoft 365 as their mail service provider can add the records as described in the following documentation:
- Verify Configuration:
- Ensure that the necessary DNS (SPF and DMARC) records are correctly configured and recognized by verifying that emails are no longer being quarantined in the recipient’s mailbox.
Internal information related
- 232991
Additional information
- Mendix documentation:
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