Issue
Unable to open the application in Studio Pro when hitting 'Edit in Studio Pro' button in Mendix Portal due to the warning message below:
Warning:
Unable to retrieve a Team Server app <ProjectID>. Make sure the
app still exists and is supported by the current version of Studio Pro. Also note that SVN apps are
not supported from Mendix 10.Environment
Studio Pro version 10.1.0 and newer
Cause
When clicking on the 'Edit in Studio Pro' button in Mendix Portal, the platform tries to start the Version Selector on the user's local machine. To do that, Mendix Portal must provide the Version Selector with the app ID and the Studio Pro version of the app.
The Mendix Portal is not aware of the Studio Pro version, so it calls the RepositoryService to check that information. Once it receives the information, Studio Pro starts and it contacts the platform to download the entire list of apps that the user has access to, after which it compares this list with the ID that was passed earlier. If the ID is not found in the list, then the error from the screenshot is shown.
At the moment, there is a concurrency issue where other components in Studio Pro can also update this list simultaneously, causing the list to be empty for a very short time.
Solution/Workaround
As this issue does not happen more often, downloading the application after a short span of time, or downloading the project using GIT CLI - as mentioned in the documentation on Team Server URL - should resolve the timeout issue.
Internal information related
- 242394, 242601, 236019
- CHQH0HJ8P/p1740731514142889 , C0A5EDRD2/p1740744363993689
Additional information
Not Applicable
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