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Expected disk space not regained during backup restore

Issue

Physical disk space can be recovered by performing a backup and restore action. A database restore does a full physical rewrite of the database. It compresses the database to contain just the current records. It also fully optimizes the physical placement of files on the actual hard disk to maximize the performance of disk read operations.

The steps to regain the physical space are: 

  1. Stop the app
  2. Create a backup
  3. Restore the backup
  4. Start the app

If the expected disk space has not been reclaimed, the database disk usage metric will not decrease following the restore, as shown in the metric below:

Environment

Applications hosted in Mendix Cloud

Cause

The database disk can still accommodate numerous large temporary files since the database instance does not restart with the steps outlined above. These files will only be cleared with a database restart. 

If the expected disk space has not been reclaimed, the database disk usage metric will not decrease following the restore, as shown in the metric below:

Solution/Workaround

Submit a Support ticket for the team to investigate whether there are numerous large temporary files. To conduct this investigation, Support will need permission from the Technical Contact to connect directly to the environment's database.

If many large temporary files are found, Support can restart the database instance to clear them.

Internal information related

  • 175317
  • [How to] Reboot Database and App with the Cloud Automation tool 

Additional information 

Mendix documentation:

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