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Sign up error "We’re not sure if you are a real human."

Issue

When signing up to Mendix, the process might throw an error with the message:

"We’re not sure if you are a real human. If you continue to experience issues, please contact our Support Team"

The information below will describe how to circumvent this error and complete your sign-up process. Please note that a company email is necessary to sign up for our platform.

Environment

Mendix Portal

Cause

The issue here is that the process is being recognized as a robot sign up when the reCAPTCHA is checked. This happens when the user is using a Virtual Private Network (VPN).

Solution/Workaround

The following steps can be tried to fix the error:

  • Deactivate the VPN for the first step, when the reCAPTCHA is checked. Afterwards, it is possible to enable the VPN once again;
  • Make sure the browser is up to date;
  • Try a different browser;
  • Try a different network;
  • Try a different device.

Typically, one of the first three steps (especially the first one) is enough to fix the issue. If the error persists after trying out all the steps, however, please contact Mendix Support.

Internal information related

  • 225659
  • C01RUAB4EDR/p1723461122255639
  • Sign-up FAQ

Additional information 

Not Applicable

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