Issue
A new user cannot sign up with Single Sign-On (SSO) on the Mendix platform. Whenever they attempt to log in, they encounter one of the following error messages:
Error: Authorization code flow operation returned with error code: access_denied, description: User is not assigned to the client application. and http status code: 302OR
Oops, It seems something went wrong there, if problem persists, please let us know.Environment
Mendix Portal
Cause
An issue in the SSO configuration causes the error. Specifically, the new user has not been assigned a role in the company's SSO/Okta group. This prevents the user from logging into the Mendix platform.
Solution/Workaround
To resolve this issue, the company Mendix Admin must assign the new user a role in the SSO/Okta group.
The new user should reach out to the Mendix Admin team to ensure their role is properly assigned in the SSO configuration. Once the role is assigned, the new user should be able to log in without issues.
Internal information related
- 228689, 209061, 222100, 183614, 182643
0 Comments