Issue
While configuring the Email Connector module, an error resembling the following stack trace is thrown:
2024-08-15T11:37:39.327877 [APP/PROC/WEB/0] ERROR - Email_Connector: Failed to connect to email server. : 535 5.7.3 Authentication unsuccessful [XXX.XXX.PROD.OUTLOOK.COM 2024-08-15T11:37:39.281Z XXX]
2024-08-15T11:37:39.327973 [APP/PROC/WEB/0] Stacktrace : com.mendix.systemwideinterfaces.MendixRuntimeException: com.mendix.datahub.connector.email.utils.EmailConnectorException: EC0x034: Error while connecting to server.
2024-08-15T11:37:39.328034 [APP/PROC/WEB/0] at com.mendix.basis.actionmanagement.ActionManager.executeSync(ActionManager.scala:109)
2024-08-15T11:37:39.328111 [APP/PROC/WEB/0] Caused by:
2024-08-15T11:37:39.328177 [APP/PROC/WEB/0] com.mendix.datahub.connector.email.utils.EmailConnectorException: EC0x034: Error while connecting to server.
2024-08-15T11:37:39.328238 [APP/PROC/WEB/0] at com.mendix.basis.actionmanagement.ActionManager.executeSync(ActionManager.scala:109)
2024-08-15T11:37:39.328335 [APP/PROC/WEB/0] Caused by:
2024-08-15T11:37:39.328402 [APP/PROC/WEB/0] EC0x034: Error while connecting to server.
2024-08-15T11:37:39.328608 [APP/PROC/WEB/0] at com.mendix.basis.actionmanagement.ActionManager.executeSync(ActionManager.scala:109)
2024-08-15T11:37:39.328736 [APP/PROC/WEB/0] Caused by:
2024-08-15T11:37:39.328778 [APP/PROC/WEB/0] Was unable to connect to SMTP server
2024-08-15T11:37:39.328844 [APP/PROC/WEB/0] at com.mendix.basis.actionmanagement.ActionManager.executeSync(ActionManager.scala:109)
2024-08-15T11:37:39.328949 [APP/PROC/WEB/0] Caused by:
2024-08-15T11:37:39.329007 [APP/PROC/WEB/0] 535 5.7.3 Authentication unsuccessful [XXX.XXX.PROD.OUTLOOK.COM 2024-08-15T11:37:39.281Z XXX]
2024-08-15T11:37:39.329123 [APP/PROC/WEB/0] at com.mendix.basis.actionmanagement.ActionManager.executeSync(ActionManager.scala:109)Environment
Email Connector (all versions)
Cause
This issue generally lies with the SMTP configuration itself, and not within Mendix.
It could be that the SMTP authentication of the user's account has not been enabled, or that the user has not configured their SMTP server correctly.
Solution/Workaround
Although a platform issue cannot be excluded, the issue likely lies with the SMTP configuration itself and not within Mendix, based on the error.
Ensure that the prerequisites of the Email Connector module are met and that the SMTP server is configured correctly.
Consult the resources under Additional Information to resolve any SMTP server issues.
Internal information related
- 224706, 218127, 200745, 226030, 127657
- C0TS72R9B/p1691402295911189
Additional information
Mendix documentation:
Other documentation:
0 Comments