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Issue loading the application in Studio Pro after upgrade. Error: System.ArgumentException: Translation Id cannot be null or empty

Issue

After upgrading the application to Studio Pro version 10.10 or 10.11 (any patch version) the error below might appear while loading the application in Studio Pro:

System.ArgumentException: Translation Id cannot be null or empty

Environment

  • Studio Pro versions: 10.10.1 and newer
  • Studio Pro versions: 10.11.1 and newer

Cause

This issue occurs if a blank name run configuration (Studio Pro > Run > Configuration) is set up for the application in Studio Pro:

Solution/Workaround

A short workaround would be to provide a name for the empty configuration before upgrading and retry. To enter the name, double click on App Settings > Configurations > select the row where the Configuration name is empty > click on Edit > provide a name.

Alternatively, upgrade to version 10.12.3 or newer, or to 10.14.1 or newer, both of which contain the fix for this issue.

Internal information related

  • 224152 
  • SPX-3544 
  • C0A5EDRD2/p1722334285290279

Additional information

Not Applicable.

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