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Unable to login after upgrade to Studio Pro 9.20+

Issue

After an application is upgraded to Studio Pro 9.20 (or newer), it is not possible to log in. This only occurs in online environments. When running the application locally, the issue does not occur. The application does not use the default Mendix login page. 

Environment

Studio Pro 9.20.0 and newer

Cause

Since Mendix Studio Pro 9.20.0, the cookie names should be prepended with  __Host-, for security reasons. A new runtime API was released to accompany this. Implementations using the old API will not set the cookie correctly on deployed environments, causing the behavior.

Solution/Workaround

If platform-supported login solutions (like SAML, OIDC, etc.) are used in the application, the module needs to be upgraded to the latest version of the module (these versions will use the new runtime API).

If a different solution is used, the new runtime API must be added manually. 

Internal information related

  • 173282

Additional information 

Mendix documentation: 

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